Prev   Next

Back to the top of the FAQ

Q. FrontPage Search Bots

A. Marj Palmer went through the grinder, and came up with this:

Thanks to all for taking the time to give me the full info on this issue. I tried Kevin's 'Map Request to NT User' suggestion on the _vit_bin directory and the results were the same...NT still popped up a dialog to validate an NT user.

I gave it some more thought and came up with a workaround that I can live with. I have a public and a private part to my web site. I don't want the general public to be able to search the entire web site, only authenticated users from the protected site. What I did is relocate the Search page containing the bot from the protected directory to the root unprotected directory. The Search page runs fine there. Most of the links to navigate to the Search page still come from a page in the protected directory. I had just one link to the Search page from the Site Map page in unprotected site. I revised the Site Map link to instead go to a search_redirect.asp page in the protected site, which after causing User authentication does a redirect to the Search page in the unprotected site. If some public user figures out how to directly type in to the search.htm they will be able to bring up and run the Search page. However, they won't be able to follow any results links to content in the private site, without getting authenticated. That's good enough for me.

Thanks again for your help. I've been very pleased with AuthentiX and the hosting support I've received fro CrystalTech. I'm rolling out the finished web site this week!

Thanks Marj, don't you just love Frontpage!

Back to the top of the FAQ

Prev   Next